OpenAFS Master Repository branch, master, updated. openafs-devel-1_9_2-552-g887c486
Gerrit Code Review
gerrit@openafs.org
Thu, 6 Aug 2026 10:55:50 -0400
The following commit has been merged in the master branch:
commit ea3c845c54a22cb2209c816778372ba5df276fec
Author: Marcio Barbosa <mbarbosa@sinenomine.net>
Date: Tue Aug 4 17:15:32 2026 +0000
fs: Split out aclu_ParseRights*() from Convert()
In preparation for upcoming commits that will move ACL-related logic
from fs.c to libacl, change Convert() to return errors to its caller
instead of exiting/asserting, and rename it to ParseRights() to better
reflect its purpose.
To allow for possibly removing DFS-specific functionality in the future,
introduce two new functions: aclu_ParseRights() for AFS ACLs and
aclu_ParseRightsDFS() for DFS ACLs. These functions are currently static
thin wrappers around ParseRights(), but upcoming commits will move them
into libacl and expose them as part of its API. Keeping them separate
avoids exposing a 'dfs' parameter in aclu_ParseRights(), preventing a
future API change if DFS support is ever removed.
Also, introduce Doxygen-style comments for both aclu_ParseRights() and
aclu_ParseRightsDFS(), since they will become publicly exposed functions
when moved into libacl.
Lastly, reintroduce Convert() as a compatibility wrapper to preserve
the current 'fs' behavior. Now, it calls either aclu_ParseRights() or
aclu_ParseRightsDFS(), depending on the ACL type, and exits on error as
before.
Change-Id: I7dd82963ce023c7bf1d9d0c2bd2759c35846adbc
Co-authored-by: Andrew Deason <adeason@sinenomine.net>
Reviewed-on: https://gerrit.openafs.org/16901
Reviewed-by: Michael Meffie <mmeffie@sinenomine.net>
Tested-by: BuildBot <buildbot@rampaginggeek.com>
Reviewed-by: Cheyenne Wills <cwills@sinenomine.net>
Reviewed-by: Andrew Deason <adeason@sinenomine.net>
src/venus/fs.c | 117 ++++++++++++++++++++++++++++++++++++++++++++++++++++-----
1 file changed, 107 insertions(+), 10 deletions(-)
--
OpenAFS Master Repository