OpenAFS Master Repository branch, master, updated. openafs-devel-1_9_2-604-g465d7a3
Gerrit Code Review
gerrit@openafs.org
Tue, 22 Sep 2026 16:19:03 -0400
The following commit has been merged in the master branch:
commit 465d7a3d678cc7c87fc7672032a303b34049e2da
Author: Andrew Deason <adeason@sinenomine.net>
Date: Mon Aug 24 12:48:34 2026 -0500
ptserver: Split out dbheader_isvalid()
We check whether our db header is valid in two different places, and the
checks are identical. Refactor the checks into a common function,
dbheader_isvalid().
Also to help readability, move our code to check if the db header is
blank into a new function, dbheader_isblank().
This commit incurs no functional change; it is just code reorganization.
Change-Id: I1feb772c775a2b28df5b431462a681010086c5ec
Reviewed-on: https://gerrit.openafs.org/16981
Tested-by: BuildBot <buildbot@rampaginggeek.com>
Reviewed-by: Michael Meffie <mmeffie@sinenomine.net>
Reviewed-by: Mark Vitale <mvitale@sinenomine.net>
Reviewed-by: Cheyenne Wills <cwills@sinenomine.net>
Reviewed-by: Andrew Deason <adeason@sinenomine.net>
src/ptserver/ptutils.c | 47 +++++++++++++++++++++++++++++++----------------
1 file changed, 31 insertions(+), 16 deletions(-)
--
OpenAFS Master Repository