[OpenAFS] openafs-1.2.2 and 2.2.19-6.2.12 kernel

Eve V. E. Kovacs kovacs@hep.anl.gov
Tue, 11 Dec 2001 17:27:18 -0600 (CST)

I am trying to build openafs 1.2.2 against Linux Redhat 6.2 
running the 2.2.19-6.2.12 kernel. (The 
openafs rpm does not work "out of the box". The libafs module fails 
to load, presumably because it was built against an earlier kernel 

When I run the make, I get the following error:
cc -c  -I/usr/include -I/usr/src/redhat/BUILD/openafs-1.2.2/src/config 
-I/usr/src/redhat/BUILD/openafs-1.2.2/include -I. -O2 uss.c
In file included from /usr/include/rx/rx.h:39,
                 from uss.c:32:
/usr/include/atypes.h:10: ktypes.h: No such file or directory

If I look in /usr/include/atypes.h, I find

#include <sys/types.h>
#include <inttypes.h>
#include <sys/bitypes.h>
#include <ktypes.h>

And indeed, there is no file /usr/include/ktypes.h.

I don't think this is really an openafs problem. It seems to be a problem 
with the 6.2 installation. I have tried removing the ktypes.h line, but 
then the code susequently fails to compile, so I conclude that this 
include file should be there.

Has anyone encountered this problem or have any idea on how to fix it/get 
around it?


Eve Kovacs
Argonne National Laboratory,
Room E253, Bldg. 362, HEP
9700 S. Cass Ave.
Argonne, IL 60439 USA
Phone: (630)-252-6208
Fax:   (630)-252-5047
email: kovacs@anl.gov