[OpenAFS] AFS oddities

Derrick J Brashear shadow@dementia.org
Wed, 7 Nov 2001 19:20:34 -0500 (EST)

On Wed, 7 Nov 2001, Blake Atkins wrote:

> I'm having strange things happen with AFS now.
> Previously, I was running OpenAFS 1.1.1a on several redhat 7.1 machines with 
> a vanilla 2.4.6 + xfs patches. Everything worked perfectly.
> I added a few machines with 2.4.9 + xfs kernels and newer versions of OpenAFS 
> with no problems. I think the latest version of OpenAFS I was using was 
> 1.2.1. Still no problems.
> Now, I'm using a RH 7.2 server with vanilla 2.4.9 + xfs as one file/db 
> server, a RH 7.1 server with 2.4.9 + xfs as a file/db server, and several 
> clients using 7.1 + 2.4.9+xfs . They're all using OpenAFS 1.2.2 and I'm 
> having strange things happen. They all start up OK and run for an indefinite 
> period of time (usually 2-8 hours). After awhile, sometimes /afs will appear 
> as a file with strange ownership/permissions.  Sometimes directories under 
> /afs will show up as the contents of a file or as total garbage. I noticed on 
> one client that when files or directores were added by another, it couldn't 
> see the changes but if it added files, itself as well as the others, could 
> see the new stuff.

In all cases is the cache partition on the same type of filesystem? If you
run tcpdump when other clients add files is the "broken" client getting
callbacks broken?

That's at least a start.