[OpenAFS] Extremely poor write performance.

Rubino Geiß kb44@rz.uni-karlsruhe.de
Wed, 22 Jan 2003 18:42:28 +0100

I've got the new arla-0.36pre11.tar.gz


gives me:

cc1: warnings being treated as errors
nnpfs_node.c: In function `nnpfs_iget':
nnpfs_node.c:226: warning: implicit declaration of function
nnpfs_node.c:226: warning: assignment makes pointer from integer without a

then I've tried:

	./configure --disable-nnpfs

witch get me to:

/usr/athena/lib/libkrb.a(str2key.o): In function `afs_string_to_key':
undefined reference to `crypt'
collect2: ld returned 1 exit status

as a last rescue i tried to cd appl/perf/ and make there; the resulting
binary has still some errors (or my setup has erros, maybe):

./afsfsperf -host i44d2 -volume 536872041 -authlevel 2
afs low-level fileserver performance tester
afsfsperf (arla 0.36pre11)
Copyright 1999-2003 Kungliga Tekniska Högskolan
Copyright 2002-2003 Stockholms Universitet
Send bug-reports to arla-drinkers@stacken.kth.se
host: i44d2, volume: 536872041, auth: auth
do the whole benchmark
Operation               total time      summary     
Can't get a token for cell unknown-cell-missing-configuration
gettime   1 times    :         3 msec    258.465 operations/s
gettime   100 times  :       145 msec    685.453 operations/s
gettime   1000 times :      1536 msec    650.897 operations/s
gettime   2000 times :      3086 msec    647.954 operations/s
afsfsperf: RXAFS_MakeDir returned 13

As far as I know I do not have "krb4 ticket file" AND google doesnt tell me!
how do i get such a file from a kaserver? Sorry maybe I'm just dumb ;)

bye, Ruby

> -----Original Message-----
> From: Love [mailto:lha@stacken.kth.se] 
> Sent: Monday, January 20, 2003 6:46 PM
> To: Rubino Geiß
> Cc: openafs-info@openafs.org
> Subject: Re: [OpenAFS] Extremely poor write performance.
> Rubino Geiß <kb44@rz.uni-karlsruhe.de> writes:
> > Thanx, but it does not help tough. The error remains the same.
> There is a arla-0.36pre11.tar.gz now, it will not assert (but 
> if you fail to have the a cell in ThisCell, you'll get the 
> cell "unknown-cell-missing-configuration".
> > An strace shows me that afsperf is trying to read some kerberosIV/V 
> > stuff like "/etc/krb.extra" and "/etc/krb.realms"... Hmmm, is it 
> > really true, that afsperf works with openafs without arla and real 
> > kerberos installation on the client and / or server? Fyi: 
> we are using 
> > kaserver.
> Yes, it will work with kaserver when you have a krb4 ticket file.
> Love