[OpenAFS] gcc reading beyond end of file on AFS

emoy@apple.com emoy@apple.com
Sat, 25 Jan 2003 01:13:40 -0800

I'm trying to compile sources on an OpenAFS server.  It compiles the  
first half dozen files fine, but on a certain file, it seems to start  
reading beyond the end of file:

gcc -arch ppc -g -Os -pipe -no-cpp-precomp -arch ppc -pipe  
-I../../include   -c -o sprint.o sprint.c
sprint.c: In function `__sio_converter':
sprint.c:661: warning: cast from pointer to integer of different size
sprint.c: At top level:
sprint.c:742: stray '\215' in program
sprint.c:742: stray '\235' in program
sprint.c:742: parse error before numeric constant
sprint.c:742: stray '\325' in program
sprint.c:742: stray '\217' in program
     (lots more similar lines)

The file itself only has 741 lines.  Copying the file locally works  
fine.  Comparing the file (with cmp) show the file is correct.  Size  
and checksum all match.  Yet the file repeatably fails.

I have tried two different servers (Mac OS X and Linux) with the same  
results, so it's probably not a server problem.  So it probably a  
client problem.

I'm using Mac OS X with OpenAFS 1.2.8, and have tried in on Mac OS X  
10.2 and 10.2.3.

Does this ring a bell with anyone?  What could gcc be doing that other  
programs don't seem to be affected.
Edward Moy
Apple Computer, Inc.

(This message is from me as a reader of this list, and not a statement
from Apple.)