[OpenAFS] Solved ( Can't mount AFS on /afs(22) / how to upgrade to 1.3.x ? )

ted creedon tcreedon@easystreet.com
Sun, 18 Apr 2004 13:04:51 -0700

I think:	 numa-i  numa-i.igpm.rwth-aachen.de

Should be	  numa-i.igpm.rwth-aachen.de numa-i


-----Original Message-----
From: openafs-info-admin@openafs.org [mailto:openafs-info-admin@openafs.org]
On Behalf Of Helmut Jarausch
Sent: Wednesday, February 11, 2004 3:55 AM
To: openafs-info@openafs.org
Subject: [OpenAFS] Solved ( Can't mount AFS on /afs(22) / how to upgrade to
1.3.x ? )

just for the record here is how I solved my long standing problem.

I had strange problems. I had a running version of OpenAFS but I
could neither upgrade OpenAFS nor the Linux kernel.
I always got 
Can't mount AFS on /afs(22)
Lost contact with volume location server ....

I still don't know why this exactly was the case but here is my "Log"
on how I fixed it.

It had to do with my (server's) hostname not being fully qualified.
I did have the fully qualified name in my CellServDB but
my etc/hosts file contains the short as well as the fully qualified name
like	 numa-i  numa-i.igpm.rwth-aachen.de

reported only the short name.
I've fixed the /etc/rc.d/init.d/network script to use the full name.
Still I then had to remove everything related to OpenAFS  except the
/vicep? partitions (luckily) and installed OpenAFS from scratch.

Now it's running just fine with kernel 2.4.24 and OpenAFS 1.3.52 .

Many thanks to all who have helped me a lot.

I hope the problems to port OpenAFS to the 2.6.x kernel series can be
overcome (soon).
Helmut Jarausch

Lehrstuhl fuer Numerische Mathematik
RWTH - Aachen University
D 52056 Aachen, Germany

OpenAFS-info mailing list