[OpenAFS] Building JAFS libraries

Horst Birthelmer horst@riback.net
Mon, 26 Jul 2004 17:19:41 +0200

On Jul 23, 2004, at 4:05 PM, Alvaro Valcarce wrote:

> Hi. Was anyone able of building the libraries libjafsadmin.so and
> libjafs.so of the OpenAFS 1.3.65?

I never tried to build it with the new sourcetree. OpenAFS 1.2.11 
worked with a few small changes.
I don't need it any more... ;-)

BTW what version of the jafs libraries are you using since IBM released 
some updates some time ago.
I think the latest code from Manuel is here:

> When I do "make jafs" from the openafs-1.3.65 directory it says that it
> cannot find the Makefile.i386_Linux24 file and I don't understand why. 
> Did
> anyone have the same problem? Thank you for your help. My output is the
> next one:
> cd src && cd libadmin/samples && make all
> make[2]: Entering directory 
> `/scratch/openafs-1.3.65/src/libadmin/samples'
> make[2]: Nothing to be done for `all'.
> make[2]: Leaving directory 
> `/scratch/openafs-1.3.65/src/libadmin/samples'
> make[1]: Leaving directory `/scratch/openafs-1.3.65'
> case i386_linux24 in \
> alpha_dux*|sgi_*|sun4x_*|rs_aix*|*linux*|hp_ux110) \
> cd src && cd JAVA/libjafs  && make all ;; \
> *) \
>         echo Not building MT libjafs for i386_linux24 ;; \
> esac
> make[1]: Entering directory `/scratch/openafs-1.3.65/src/JAVA/libjafs'
> Makefile:31: ../../config/Makefile.i386_linux24: No such file or 
> directory
> make[1]: *** No rule to make target 
> `../../config/Makefile.i386_linux24'.
> Stop.
> make[1]: Leaving directory `/scratch/openafs-1.3.65/src/JAVA/libjafs'
> make: *** [libjafs] Error 2

AFAIK the Makefile.<platform> variants are discontinued. They simply 
aren't used any more.
Go into the directory and try make. Eventually you have to change some 
path. It shouldn't be such a big deal ... but if you're trying to use 
those libraries you'll notice pretty quick that they're hopelessly out 
of date.