[OpenAFS] AFS, Kerberos 5 and OpenSSH - Need HELP

Padiyath Sreekumaran Kumar.Padiyath@psi.ch
Fri, 18 Jun 2004 15:23:27 +0200


   Iam trying to install Kerberos 5(with SIA) with AFS and OpenSSH.

   At present we use Kerberos 4 with AFS.

   The situation is like this:

   OS  : Tru64 V5.1A

   IBM AFS 3.6 client version

   I tried with the following SW versions without success:

   OpenSSL version tried :  openssl-0.9.7d
   Kerberos 4    version   :   krb4-1.3rc1
   Kerberos 5 version      :   heimdal-0.6.2


      I did the following:  
         Openssl         : Compiled with cc and installed in
                          /usr/local/ssl directory.(env "CC=cc" /Configure)

   Kerberos 4 installation:   Installed in default directory /usr/Athena
                      (env "CC=cc" ./configure --with-openssl=/usr/local/ssl


    Heimdal installation : Installed in /usr/local directory
                   (env "CC=cc" ./configure --with- krb4=/usr/athena 
--with-krb4-include=/usr/athena/include --with-openssl=/usr/local/ssl
--with-openssl-include=/usr/local/ssl/include --with-x)

    After installation of heimdal 
    when I try to execute /usr/local/bin/kinit command I get the following
error and a core dump.

     #/usr/heimdal/bin/kinit gsell   

     gsell@AFSTEST.PSI.CH's Password: 

     kinit: Fatal: could not seed the random number generator

     resources lost(coredump)

     I would like to know the following:

   1.   Which version of OpenSSL , Kerberos 4 , Kerberos 5(with SIA) and
        OpenSSH I have to use?
   2.   Which Compile I have to use?
   3.   Has any one installed these SW on their machines?

        Any of use Kerberos 5 library with SIA in Tru64?
        I will appreciate very much if any one can give some help.
        I have the config.log and make output saved in a file from Heimdal.

         Thanks in advance,