[OpenAFS] 1.2.11 openafs - RedHat Update 3 x86_64

Troy Dawson dawson@fnal.gov
Mon, 20 Sep 2004 17:01:47 -0500

I'm having trouble recompiling a kernel module for the kernel for RedHat 
  Enterprise Update 3, for the x86_64 architecture.  This is kernel 
I have no problem recompiling it for the i386, or the ia64 (itanium). 
It is only for the x86_64 architechture.
Now I will be honest, this is actually a recompiled RedHat release, not 
a true redhat release, but as soon as I find a real RH x86_64 I'll give 
it a try.  But I have tried it on Scientific Linux, and CentOS, both of 
which give the same error, so I'm thinking it's the kernel thing.
I also have built the kernel modules for all the RedHat kernels up until 
the 2.4.21-20.EL on the same machine, right before doing that one kernel.

Well, anyway, here is the error.  This is while doing an rpm build. 
I've cut out all the stuff at the top.  I can send it if needs be, but 
this end part seems to be the critical stuff.


gcc  -O2 -fomit-frame-pointer -fno-strength-reduce -fno-strict-aliasing 
-fno-common -pipe -mcmodel=kernel -D__KERNEL__ -DKERNEL -D_KERNEL 
-I/usr/src/redhat/BUILD/openafs-1.2.11/src/config -c ../afs/osi_alloc.c
gcc  -O2 -fomit-frame-pointer -fno-strength-reduce -fno-strict-aliasing 
-fno-common -pipe -mcmodel=kernel -D__KERNEL__ -DKERNEL -D_KERNEL 
-I/usr/src/redhat/BUILD/openafs-1.2.11/src/config -c ../afs/osi_cred.c
gcc  -O2 -fomit-frame-pointer -fno-strength-reduce -fno-strict-aliasing 
-fno-common -pipe -mcmodel=kernel -D__KERNEL__ -DKERNEL -D_KERNEL 
-I/usr/src/redhat/BUILD/openafs-1.2.11/src/config -c ../afs/osi_groups.c
../afs/osi_groups.c:181: syntax error before "old_gid_t"
../afs/osi_groups.c:182: syntax error before "old_gid_t"
../afs/osi_groups.c: In function `afs32_xsetgroups':
../afs/osi_groups.c:194: `gidsetsize' undeclared (first use in this 
../afs/osi_groups.c:194: (Each undeclared identifier is reported only once
../afs/osi_groups.c:194: for each function it appears in.)
../afs/osi_groups.c:194: `grouplist' undeclared (first use in this function)
make[4]: *** [osi_groups.o] Error 1
make[4]: Leaving directory 
make[3]: *** [linux_compdirs] Error 2
make[3]: Leaving directory `/usr/src/redhat/BUILD/openafs-1.2.11/src/libafs'
make[2]: *** [libafs] Error 2
make[2]: Leaving directory `/usr/src/redhat/BUILD/openafs-1.2.11'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/openafs-1.2.11'
make: *** [only_libafs] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.69349 (%build)

RPM build errors:
     Bad exit status from /var/tmp/rpm-tmp.69349 (%build)


Any idea's as to the problem,  and or the solution?

Troy Dawson  dawson@fnal.gov  (630)840-6468
Fermilab  ComputingDivision/CSS  CSI Group