[OpenAFS] Debian - openafs -noauth problems

Madhusudan Singh singh.madhusudan@gmail.com
Wed, 24 Aug 2005 16:01:38 -0400

On Wednesday 24 August 2005 3:33 pm, Russ Allbery wrote: 

> Madhusudan Singh <singh.madhusudan@gmail.com> writes:
> > Thanks for your exhaustive response.
> > I ran the afs-newcell script :
> >
> > What administrative principal should be used? zzzz/admin
> > echo \>omega.domain.edu >/etc/openafs/server/CellServDB
> > /etc/init.d/openafs-fileserver start
> > Starting AFS Server: bosserver.
> > bos addhost omega omega -localauth ||true
> > bos: could not find entry (can't find cell '<default>' in cell database)
> This looks like the old version of afs-newcell.  If you could give the new
> version of afs-newcell that was posted to the list a while back a try,
> that would be great.  (In the current development version, I've tried to
> fix this problem separately in two different places, but the afs-newcell
> fix should be sufficient.)

Thanks for catching that.

Just ran it :
Do you meet these requirements? [y/n] y
If the fileserver is not running, this may hang for 30 seconds.
/etc/init.d/openafs-fileserver stop
Stopping AFS Server: bosserver.
What administrative principal should be used? m_singh/administrators

/etc/openafs/server/CellServDB already exists, renaming to .old
/etc/init.d/openafs-fileserver start
Starting AFS Server: bosserver.
bos adduser omega m_singh.administrators -localauth
Protection database already exists; cell already partially created
bos removeuser omega m_singh.administrators -localauth

# bos status omega -local

No o/p.

Your README suggested that I should see some processes started now. Maybe some 
remnants of the old setup are interfering now.

Only bosserver is running right now.