[OpenAFS] a familiar problem compiling aklog?

Ken Hornstein kenh@cmf.nrl.navy.mil
Wed, 14 Dec 2005 11:30:25 -0500

Russ has provided a good answer to you email; I only have a few things
to add:

I only can test on systems I have easy access to; for various political
reasons here, I only have easy access to Solaris and MacOS X, and I only
use MIT Kerberos (I installed Heimdal on a Solaris box here just so I could
test it).  Hence aklog compiles fine on those systems.  Other people are
going to have to step up to the plate and figure out what to do under Linux.
But this probably means solving the "real" problem and figure out what
do regarding com_err ... and that's a hard problem.

>2) people aren't compiling AFS on Linux from source but installing 
>binaries (which is a bit of a crock--somebody's compiling the binaries 
>initially somewhere, and they'd have the same problem)

The pre-built binaries are not currently compiled with aklog, or they
ship with some older version of aklog; you'd have to talk to the people
who build these binaries (that would be Russ & others on Linux) but
part of the problem is that since there are a number of Kerberos libraries
out there, there is no one good answer for which Kerberos library version
you should use.

>3) people aren't using the openAFS 1.4.0 source but some earlier version 
>which does not have the problem

Like Russ said ... versions earlier than 1.4.0 don't have this problem,
because they don't provide aklog.

>OpenAFS is in a pretty small group of programs I've encountered that did 
>not ./configure && make && make install without tweaking.

You clearly have not compiled many programs with Kerberos support; I
have, and they ALL required some tweaking (the worst were the ones that
used the CMU autoconf code that tried to guess where Kerberos was ...
that code NEVER worked for me).  It's better now that there is the
krb5-config script that autoconf can use to find out the right options
to use for Kerberos, but I guess openafs is the first publically
distributed package that uses it.

(And to be fair; you have to provide extra options to ./configure to enable
aklog to get compiled, so it's not just ./configure && make && make install).