[OpenAFS] vos replication being strange.

Chris Huebsch chris.huebsch@informatik.tu-chemnitz.de
Fri, 6 May 2005 22:35:56 +0200 (CEST)

On Sat, 7 May 2005, Eric Bennett wrote:

> You're right, /vicepa on corvus went boom, I have no idea how or why, but 
> it's definitely gone, it was a loopback file from a local filesystem and when 
> the system was rebooted the original file disappeared entirely.

A Loopback-file? I hope, you are just testing AFS...
If you want to "fake" a partition you can use an empty file named
"AlwaysAttach" in the /vicepX-directory. It will be used as a partition
even if its not a true  partition.

> Is it possible to copy the volumes from raven or do they need to be
> remade in their entirety? I've tried vos copy root.afs raven /vicepa
> root.afs corvus /vicepa -verbose but it just says the volume already
> exists, so I then tried a syncvldb thinking that perhaps the vldb
> needed to know there was a problem but it reported successful and
> still lists corvus' old volumes in listvldb.

> Anyone have any ideas?

There are a lot of commands, which manipulate the vl-db (just do a vos

My favourite command would be "vos convertrototw" (or like that).

If your version does not have this command, try "vos dump" and "vos
restore" to dump your volumes into a file and restore them as

Good luck

Chris Huebsch    www.huebsch-gemacht.de | TU Chemmnitz, Informatik, RNVS
GPG-Encrypted mail welcome! ID:7F2B4DBA |   Str. d. Nationen 62, B204
  Chemnitzer Linux-Tage 2006, 4.-5.Maerz |       D-09107 Chemnitz
     http://chemnitzer.linux-tage.de/    |  +49 371 531-1377, Fax -1803