[OpenAFS] operation timeout

Pucky Loucks ploucks@h2st.com
Thu, 3 Nov 2005 22:05:09 -0800

posted this sto the devel list but didn't see it some through.

I have a cell running 1.4.0-rc8 with 6 servers in total and a client  
running 1.4.1rc1 OSX 10.4.2.

3 afs db's
3 fileservers
1 osx client

currently I have an application that load balances writes to the 3  
file servers.  For example when I need to write a file I call my  
FileManager class and ask for a file, which it returns a created file  
from one of the 3 fileservers and the application writes to the  
FileOutputStream.   Currently round robin writes happen to 1 of the  
three servers.  While my application is running full steam writing  
files, I've shut down fileserver3, which is fine because the  
FileManager class tries to write to that server get's an exception  
and then tries the next inline until it can create the file.  All is  
good at this point, until I bring fileserver3 backup (I'm really just  
doing a "bos stop fileserver3 fs" and "bos start fileserver3 fs") I  
still get an exception "Operation timed out" and no new files are  
written to fileserver3.

I've opened a terminal and tried to create a file in a volume that is  
on fileserver3 and I get the " Operation timed out", but when I try  
the same thing from a 1.4.0-rc8 box it works fine.  So in short it  
looks like a bug in the Mac 1.4.1-rc1. (which is running the  
application and using the afs client to write to the cell)

What info can I get you to verify that this a bug in the OSX latest