[OpenAFS] 1.4.0 on Solaris 10 x86/amd64

Kris Kasner tkasner@qualcomm.com
Mon, 7 Nov 2005 08:48:45 -0800 (PST)

Hi Folks

Is anyone successfully using 1.4.0 on Solaris 10 x86 amd64 with Solaris booted 
64bit (the default)?

I tried multiple compiles of rc4-8, both with the latest GCC and with 
SunStudio10 (fully patched), and once the full release came out, I tried the 
binary release available at OpenAFS.org, all with the same exact results..

If I boot 32bit (boot-file=kernel/unix, isainfo=i386) everything works 

If I boot 64bit (boot-file=kernel/amd/unix or boot-file='', isainfo="amd64 
i386"), any attempt to access data from AFS results in "no such device", yet 
things like "vos exa root.afs" work perfectly and tell me everything about any 
volume I pick.

I'm running this on a Sun W2100Z with 2 2.6GHz AMD 252's and 2GB memory.

Anyone out there running in 64bit mode successfully? If so, are you single or 
dual CPU, etc?



Thomas Kris Kasner                  Qualcomm Inc.
UNIX Infrastructure Architecture    5775 Morehouse Drive
UNIX Systems Administration 	    San Diego, CA 92121

   ...take what you can from your dreams
 	Make them as real as anything
 	It'd take the work out of the courage
 					-- Dave Matthews "Grey Street"