[OpenAFS] 1.4.0.rc6 , make install not working ?

Ron Croonenberg ronc@depauw.edu
Mon, 10 Oct 2005 09:39:35 -0500

Hello all,

I uninstalled the OpenAFS-1.2.13 rpm's  and tried to install the
OpenAFS-1.4.0.rc6 binaries by doing a "make install"

I read INSTALL, NEWS and README  (even tried a make check, but that one
says "No rule to make target `check'.")

I assume "make install" is used to install the 1.4.0.rc6 release ... 
right ?

All the binaries are there, but for all directories that make enters I
get msgs like: 
make[3]: Entering directory `/opt/OpenAFS/openafs-1.4.0-rc6/src/pam'
make[3]: Nothing to be done for `install'.
make[3]: Leaving directory `/opt/OpenAFS/openafs-1.4.0-rc6/src/pam'

the files that need to be installed are really there (here's the listing
for the pam directory) :
[root@oort pam]# ls
afs_account.c                   afs_pam_msg.o      Makefile
afs_account.o                   afs_password.c     Makefile.in
afs_auth.c                      afs_password.o     mapfile
afs_auth_krb.o                  afs_session.c      mapfile.hp
afs_auth.o                      afs_session.o      pam_afs.5
AFS_component_version_number.c  afs_setcred.c      pam_afs.krb.so.1
AFS_component_version_number.o  afs_setcred_krb.o  pam_afs.so.1
afs_message.c                   afs_setcred.o      test_pam
afs_message.h                   afs_util.c         test_pam.c
afs_message.o                   afs_util.h         test_pam.o
afs_pam_msg.c                   afs_util_krb.o
afs_pam_msg.h                   afs_util.o