[OpenAFS] OpenAFS 1.3.87 and 1.4.0-rc6 stability issues on Solaris 10

Logan O'Sullivan Bruns logan@gedanken.org
Tue, 11 Oct 2005 11:34:29 -0700

I'm using the "nonfs" version. It's not a big problem for me and I
wouldn't have even noticed it except that I have a few netras without
cdrom drives. In any case, it's pretty infrequent that I have to use
it as a boot server. I just figured since some developer will probably
be doing some testing to fix the problem you found that they might be
interested in the other problem.


On Tue, Oct 11, 2005 at 08:17:23PM +0200, Loic Tortay wrote:
> According to Logan O'Sullivan Bruns:
> >
> > For whatever it's worth I was able to reproduce the behavior you
> > described with 1.4.0-rc4 on Solaris 10 (sparc).
> >
> Thanks, I guess that presumably reduces the possibility of a
> configuration error on my side.
> >
> > Another problem I've seen consistently on Solaris 10 is that if the
> > NFS server is put under load while the AFS kernel module is loaded the
> > system panics. I ran into this initially while doing a net install of
> > Solaris 10 on a netra without a CD drive. I tried it several times
> > with AFS loaded and it paniced every time then when I disabled the
> > script to load the AFS module it worked fine. Anyway, another thing to
> > check if an AFS developer wants to spend some time testing on Solaris
> > 10.
> >
> I have not seen this, but I don't have an AFS client running Solaris
> 10 that is also a NFS server, anyway this may be due to using the kernel
> module with the NFS translator.
> Are you using the "nonfs" kernel module ?
> Lo?c.
> -- 
> | Lo?c Tortay <tortay@cc.in2p3.fr> -     IN2P3 Computing Centre     |