[OpenAFS] Trouble compiling 1.4rc4 SRPM

Derek Atkins warlord@MIT.EDU
Fri, 23 Sep 2005 14:32:33 -0400

Quoting Christopher Allen Wing <wingc@engin.umich.edu>:

>>> There are also a number of other patches to afs-krb5 I've accumulated in:
>> I've grabbed some that I consider relevant.  I didn't grab all of 
>> them.  I tried
>> to ignore the UMich-specific stuff, and as I don't build/install afs2k5db I
>> just ignored that set completely.
> Sure. Most are build fixes from my experience getting it to compile 
> on Linux and/or Solaris.

Solaris I'll believe.  I'm only looking at Linux.  I don't have any 64-bit
platforms to test on, only x86.  That's why I missed the res_search issue.  It
built fine on all my (x86) platforms.

> I included afs2k5db and fakeka, so that people could test out a 
> server with less effort. (I put them in a separate 
> 'openafs-server-krb5' package, though).

Yea.  I just decided to ignore those.  I suppose I could try to build and
install fakeka if people seem to want it.

> Some people have asked to include 'asetkey' in the OpenAFS source, 
> but I think this is unnecessary- can't you do the same thing with 
> 'klist -K' and 'bos addkey'? (though you'd have to convert hex to 
> octal)

I dont think you need to do the conversion.  It worked just fine for me from
klist -K.  But I DO distribute asetkey in my packages.

>> As for the rest...  I only applied patches when I seemed to have a 
>> problem with
>> the build.
> Are you planning on creating/maintaining 'official' OpenAFS 1.4.x 
> RPMs for RHEL 4?

Yes.  I've already got packages of 1.4.0rc4 up (which is where this all
started).  I've also incorporated patches to fix the two issues so far 
here (well, one here and one to me personally)..  And I still have to figure
out how to rename the module under 2.6  (I want the module named "openafs" but
somehow the module seems to think its name is "libafs").

I could also probably improve the initscripts....

> Thanks,
> Chris


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord@MIT.EDU                        PGP key available