[OpenAFS] SOLVED: ioctl on afs_ioctl blocking forever

David Broudy dave@broudy.net
Sat, 22 Apr 2006 16:41:33 -0600

I traced the problem down to when afsd was mounting /afs, it was the 
mount call that was blocking. tcpdump showed that afsd was requesting 
root.afs and it was being resolved to it's RO id, and that was it, it 
was hung. The root problem was that I had duplicate entries for all my 
replicated volumes in the vldb, ie:

    RWrite: 536870912     ROnly: 536870913     Backup: 536870914
    number of sites -> 3
       server minerva.vpn.broudy.net partition /vicepa RW Site
       server goliath.arl.broudy.net partition /vicepa RO Site
       server minerva.vpn.broudy.net partition /vicepa RO Site
       server minerva.vpn.broudy.net partition /vicepa RO Site

Before the problems started, I had entries minerva.broudy.net (external) 
and minerva.vpn.broudy.net (internal vpn) that afs created at some point 
during my change to using a vpn to avoid nat issues. I never added 
duplicated entries for minerva two names manually. When I noticed these 
entries, I did a vos changeaddr, which apparently was a dumb idea, 
because it created exact duplicates, which caused massive breakage.

David Broudy wrote:
> After deciding that openafs was never going to work quite right with 
> my nat a few days ago (thanks Jeffery), and that I probably need to 
> create a vpn anyway, I did and changed the addresses to run over that. 
> It worked great for a couple days, but now aklog and other afs tools 
> are blocking forever on:
> open("/proc/fs/openafs/afs_ioctl", O_RDWR) = 4
> This is after aklog already produced output:
> Authenticating to cell broudy.net (server minerva.vpn.broudy.net).
> We've deduced that we need to authenticate to realm BROUDY.NET.
> Getting tickets: afs/broudy.net@BROUDY.NET
> About to resolve name dave.admin to id in cell broudy.net.
> Id 1
> Set username to AFS ID 1
> Setting tokens. AFS ID 1 /  @ BROUDY.NET
> This is happening on all my clients, and tcpdump doesn't seem to show 
> any afs related network traffic while this is happening. I've tried 
> this with and without afsdb configured. I see this question was asked 
> before on the list, but there was never an answer posted that I can find.
> Thanks in advance,
> Dave

Dave Broudy
Phone: 303.278.0908      Mobile: 703.401.5955        Fax: 303.674.6840
AIM/YIM: dbroudy