[OpenAFS] Re: Linux-VServer and openAFS

"Einar S. Idsų" esi@itk.ntnu.no
Sun, 21 May 2006 04:42:56 +0200

David Broudy wrote:
> Sorry, I tried it under UML. Didn't realize linux-vserver was different.

Thanks for your response nevertheless :)

I've just made a breakthrough! It seems the problem I was having was
unrelated to vserver after all: Running strace on bosserver, I noticed a
reference to /var/lib/openafs/logs/BosLog (*slaps head*) which contained
the following:

Sun May 21 04:17:52 2006: Server directory access is okay
Sun May 21 04:17:52 2006: could not create cell database in
'/etc/openafs/server' (code 70354688), quitting

A quick Google for the error message led me to the source-files which
showed me that 'code' is the output from gethostname(). I then
remembered that I have recently changed the hostname of the computer
without modifying /etc/hosts. So I fixed /etc/hosts, and bosserver seems
to be running nicely now!

I'll get back to you when I run in to my next problem... Now I have to
get some sleep.