[OpenAFS] status of samba serving AFS file space? other non-native windows access?

Christopher D. Clausen cclausen@acm.org
Mon, 16 Oct 2006 15:09:54 -0500

Dan Pritts <danno@internet2.edu> wrote:
> some of it has been mysterious issues with changes not being saved.
> I think this is really because they are simultaneously editing AFS
> files with MS office, because they refuse to drag files to their
> desktop before opening and the 1.4 client we're using doesn't try to
> create any AFS locks.   Yes i know that 1.5 should solve this problem
> but i've been worried what else will happen with the unstable branch.
> The situation is a lot better with the 1.4.2 rc client, but they're
> at the point that they have lost patience with problems and I need to
> give them something that just works.  I'm hoping to avoid that
> solution being a windows file server, since we will continue to use
> afs within the organization, but it's not out of the question.

I'm pretty sure you are going to end up with more locking problems, not 
less, going through both samba and AFS.

I'd suggest actually reporting the problems you have to
openafs-bugs@openafs.org so that they can be fixed.  Fixing the bugs is 
likely be a faster solution than deploying and testing samba with AFS.

I'd also ask what version of the server code you are running.  I had 
some issues with large powerpoint documents becoming complete garbage 
but I'm pretty sure it was related to server problems and since we've 
upgraded to a patched 1.4.2fc4, we haven't had further problems.

Have you tried enabling the "Offline Folders" functionality of Windows 
to see if that helps reduce the problems?

I'll note that I run the 1.5.X series of clients in production, although 
the 1.5.0901 builds seem to have serious problems when mount points or 
symlinks are removed, but this has only really affected me as most users 
do not need to use such features, especially from Windows.  (And yes, I 
have reported these bugs so that they can be fixed.)  Generally 
"unstable" just means "newer features."  Occationaly certain builds are 
completely hosed, but that happens with the 1.4.X FCs as well.

Christopher D. Clausen