[OpenAFS] OpenAFS 1.4.2 on latest FC5 kernel

Derek Atkins warlord@MIT.EDU
Thu, 26 Oct 2006 09:21:23 -0400

Ingemar Nilsson <init@pdc.kth.se> writes:

> Matthew Andrews <matt@slackers.net> writes:
>> Building the openafs kernel module on the latest FC5 kernels fails.
>> I am rebuilding the FC5 rpms for the 2.6.18-1.2200.fc5 kernel and see
>> the following build failure
> I tried the same thing, but I got another error message (during configure):
> checking your OS... configure: error: No usable linux headers found at /lib/modules/2.6.18-1.2200_FC5/build 
> I have both the kernel and the kernel-devel packages installed, and this
> worked fine with the OpenAFS 1.4.1 source-RPM and previous FC5 kernels. My
> build command was
> rpmbuild --rebuild --target=`uname -m` --define "kernvers 2.6.18-1.2200_FC5" --define "build_userspace 1" /home/init/Downloads/openafs-1.4.2-fc5.1.src.rpm

The kernvers is wrong.   Run "uname -r" and you'll see!
I recommend you just let rpmbuild determine the current kernel version.

> Regards
> Ingemar


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord@MIT.EDU                        PGP key available