[OpenAFS] little oddity in 1.4.2

Scott Peshak speshak@iastate.edu
Fri, 27 Oct 2006 10:29:59 -0500

On 10/27/06, Juha J=E4ykk=E4 <juolja@utu.fi> wrote:
> Hi!
> After upgrading to 1.4.2, I have started to get these (probably any bos
> command will do - I tried the most common ones):
> bos: could not find entry (can't find cell '<default>' in cell database)
> Also, /etc/init.d/openafs-fileserver stop produces the above and fails to
> shut down anything else but bosserver.
> Also, FileLog has started to tell me that "afs_krb_get_lrealm failed,
> using tfy.utu.fi." at the same time. It works fine, though.
> There were no changes to the configuration, simply the file server
> version upgrade. Is this a bug or a misconfiguration that has worked
> previously but no longer does?

I had a similar error when I upgraded to 1.4.2 (I don't remember the
exact text now, but it had something to do with the <default> cell)
The fix ended up being adding a blank line to ThisCell. Everything
worked fine with previous versions without the extra newline, but
something must have changed in 1.4.2 that made it required.