[OpenAFS] openafs kernel module on Fedora Core 6 [Load Failure]

Mike Polek mike@pictage.com
Tue, 23 Jan 2007 19:57:32 -0800

There is a "bug" (undocumented feature?) in the FC6 installer.
It installs the i586 kernel by default, even when all the
older installers would detect that you had a machine capable
of using the i686 kernel.

On the install media, There should be a
Fedora/RPMS/kernel-2.6.18-1.2798.fc6.i686.rpm file.
Normally, you would NEVER use -U for a kernel rpm,
but in this case, you actually want to replace your i586
kernel with the i686 version.... so ...

rpm -Uvh kernel-2.6.18-1.2798.fc6.i686.rpm

and you might need to use --force at the end of that if it

Double check that your grub.conf has the right stuff.
I don't think it should actually change, but I always check
it for safety. When you reboot, you should have the i686
kernel. You can then load your i686 module.

Worked for us here.

Optionally, you an also just download an rpm for the newer
2.6.18-1.2869.fc6 kernel (or whatever the latest
and greatest is at the moment) for i686, install that, and
build an openafs kernel module for it. That's what we're
using now.


Anirbid Banerjee wrote:
> Hi,
> I have installed Fedora Core 6.0 (2.6.18-1.2798.fc6 #1 SMP i686 i686
> i386 GNU/Linux) on my system. I installed the kernel source from
> kernel-devel-2.6.18-1.2798.fc6.i686.rpm.I tried getting an appropriate
> AFS client for this system. Unfortunately I could not find any, so I
> started building one myself.
> Except for commenting out a few of these lines #include <linux/config.h>
> in the openafs-1.4.2 source tree, (I learnt that
> /include/linux/config.h is officially removed from source trees higher
> than 2.6.18) I didnt make any significant changes. The package builds
> fine alongwith the kernel module, but I cannot modprobe the module
> into the kernel.
> This is what it says:
> $ modprobe libafs
> FATAL: Error inserting libafs
> (/lib/modules/2.6.18-1.2798.fc6/kernel/fs/openafs/libafs.ko): Invalid
> module format
> $dmesg | tail -1
> libafs: version magic '2.6.18-1.2798.fc6 SMP mod_unload 686 REGPARM
> 4KSTACKS gcc-4.1' should be '2.6.18-1.2798.fc6 SMP mod_unload 586
> I am not getting any idea how to tackle this problem. Please suggest.
> ~$u8h
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info

Michael Polek
Director of System Operations
1580 Francisco Street, Suite 101
Torrance, CA 90501
Phone: (310) 525-1600 ext. 628
Email: mike@pictage.com

This message, together with any attachments, is intended only for the use of
the individual or entity to which it is addressed. It may contain
information that is confidential and prohibited from disclosure. If you are
not the intended recipient, you are hereby notified that any dissemination
or copying of this message or any attachment is strictly prohibited. If you
have received this item in error, please notify the original sender and
destroy this item, along with any attachments.