[OpenAFS] trouble running programs out of AFS after imaging

Dean Knape knape@njit.edu
Mon, 12 Nov 2007 10:36:55 -0500

Christopher D. Clausen wrote:
> Dean Knape <knape@njit.edu> wrote:
>> I have a W2K3 R2 server VM with OpenAFS 1.5.26 provisioned from a
>> sysprep image.
>> When I try to run a program out of AFS from explorer I get "Windows
>> cannot access the specified device, path, or file. You may not have
>> the appropriate permissions to access the item.".  Running the same
>> programs from a command line works correctly.  ACLs are correct.  I
>> get the same error with and without token. Refreshing the AFScache
>> file did not help.
> What application?
> Could you copy the application in question to local disk?  (E.g. did you 
> actually have read access to it?)
> fs checks & fs checkv & fs flusha
> and try again.
> <<CDC
For testing and example, I've installed perl and and SSH client in AFS.

Start -> Run -> \\afs\uis\platform\local\platform\Perl\bin\perl.exe -V or 
                \\afs\uis\platform\local\@sys\SSH Secure Shell\SshClient.exe

Both fail with error described above.

If I copy either of these to local disk they do run.  If I run either of
these from a command line they do run.

fs checks & fs checkv & fs flusha did not help.

After debugging and preparing for bug submission I uninstalled 1.5.26 and
upgraded to 1.5.27.  Still cannot run from explorer.

Logs and detailed description sent to openafs-bugs.