*** Spam *** Re: [OpenAFS] AFS Fileserver Won't Start --> Can't Release root.cell or root.afs

Kim Kimball dhk@ccre.com
Fri, 05 Oct 2007 07:07:07 -0600

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
<body bgcolor="#ffffff" text="#000000">
Have you tried changeaddr from to &lt;whatever the IP address
of server is&gt; ??<br>
You might also try <br>
vos remove &lt;server&gt; &lt;partition&gt;
&lt;volumename&gt;.readonly&nbsp;&nbsp;&nbsp;&nbsp; #for each readonly instance<br>
vos backup &lt;volumename&gt;<br>
vos dump &lt;volumename&gt;.backup | vos restore &lt;server&gt;
&lt;partition&gt; &lt;volumename&gt; -overwrite full<br>
Use the same volume name for each instance of &lt;volumename&gt;<br>
This will give you a new volumeID for &lt;volumename&gt; which will be
reflected in the VLDB.<br>
Then "vos addsite" to replace the RO sites.<br>
Then "vos release"<br>
Christopher D. Clausen wrote:
<blockquote cite="mid:31840886.1191560299507.JavaMail.root@m11"
  <pre wrap="">Karl M. Davis <a class="moz-txt-link-rfc2396E" href="mailto:karl@ridgetop-group.com">&lt;karl@ridgetop-group.com&gt;</a> wrote:
  <blockquote type="cite">
    <pre wrap="">I then tried running "vos changeaddr -oldaddr -remove", but
it looks like some of my volumes are still "stuck" on the old IP:

karl@picacho:~$ sudo vos changeaddr -oldaddr -remove
-localauth -verbose
Could not remove server from the VLDB
VLDB: volume Id exists in the vldb
  <pre wrap=""><!---->
I'd say to try and get a good vos dump of each volume that you care 
about so that you can at least restore to a new cell if things go bad 
from here.

Usually I'd fix this finding the volume that is listed as being on that 
IP and moving it to another server :-)  But it would seem that you have 
already done that.  I guess its possible that the vldb still thinks that is one of the servers somehow.  Did you try restarting your 
file servers?

Does vos syncvldb/syncserv do anything useful for you?  If not, it 
should be safe to shutdown the AFS server and delete the VL db files and 
have them get recreated at server startup.  (Might need to delete the 
sysid file as well.)

Or, vos dumping, deleting, and recreate each volume via vos restore may 
fix it, assuming you have fixed all problems.

  <blockquote type="cite">
    <pre wrap="">How would I go about resolving this?  By the way, thanks very much
for all of your help so far; you've really saved my ass on this.
  <pre wrap=""><!---->
No problem.  I'm glad it helped.


OpenAFS-info mailing list
<a class="moz-txt-link-abbreviated" href="mailto:OpenAFS-info@openafs.org">OpenAFS-info@openafs.org</a>
<a class="moz-txt-link-freetext" href="https://lists.openafs.org/mailman/listinfo/openafs-info">https://lists.openafs.org/mailman/listinfo/openafs-info</a>