[OpenAFS] Re: atrpms for fedora openafs?

Simon Wilkinson sxw@inf.ed.ac.uk
Sat, 15 Mar 2008 19:58:38 +0000

On 15 Mar 2008, at 19:29, Marc Dionne wrote:
> As for F9, I just tried building OpenAFS with a F9 kernel, but this  
> currently fails because of GPL only symbols that get dragged in by  
> some kernel debugging options (as discussed in another thread):
> - lock statistics brings in mutex_lock_nested() which is GPL

Yes - this stopped me in my tracks last time I tried some F9/rawhide  
builds (at that point against 2.6.24). There's not much we can do  
when mutexes aren't available.

> - lockdep brings in some rcu GPL symbols

I think we can fix this, by adding a configure test that checks if  
rcu_read_lock is available to us, and just disables the code in  
osi_keyring_init() that uses the task list to set __key_type_keyring  
if it isn't (On 2.6.24, key_type_keyring is exported, so gets picked  
up by weak reference). I started on this work, but never completed it  
as I couldn't find a shipping kernel that had this problem, but still  
let us use mutexes!

It looks like there may also be a problem with  
afs_osi_TraverseProcTable (in the GCPags code).

> These will probably be disabled once F9 is released,

My understanding is that the release kernel won't have these  
debugging options enabled, yes.