FW: [OpenAFS] /afs area is hanging

Wheeler, JF (Jonathan) jonathan.wheeler@stfc.ac.uk
Wed, 29 Apr 2009 08:07:27 +0100

-----Original Message-----
> From: openafs-info-admin@openafs.org On Behalf Of Mark Henry
> Sent: 28 April 2009 23:22
> I have an OpenAFS client that works after each reboot and then
> hangs when the afs area is accessed.  I am running openafs 1.4.9 that
I compiled
> on the system (I have tried many versions of the openafs client with
the same
> results).  The OS is OpenSUSE 10.3.  I have two other systems with the
> OS that are working fine.
> I have searched /var/log/messages.  I have checked the config files.
> authentication works fine (even when the system is hanging).  If I run
> command 'ls -l /afs' that window is hung.  If an afs user logs in when
> system is in a bad state the session immediately hangs because it
can't cd
> to the afs home dir.  I don't know what to do other than reboot.  Can
> tell me what else to try to find out why this system is hanging?

If you really are using the command "ls -l /afs", I have always
understood that this is getting information about the whole of AFS
space, that is, the root directories for all AFS cells; naturally this
will take a long time.  This may not solve your problem, but the command
as given is a bad (TM) idea.  Of course, the command "ls -l
/afs/CELLNAME" where CELLNAME is the name of your cell is a much better

Jonathan Wheeler=20
e-Science Centre=20
Rutherford Appleton Laboratory
(Cell rl.ac.uk)
Scanned by iCritical.