FW: [OpenAFS] /afs area is hanging

Felix Frank Felix.Frank@Desy.de
Wed, 29 Apr 2009 09:21:43 +0200 (CEST)

On Wed, 29 Apr 2009, Wheeler, JF (Jonathan) wrote:

> -----Original Message-----
>> From: openafs-info-admin@openafs.org On Behalf Of Mark Henry
>> Sent: 28 April 2009 23:22
>> I have an OpenAFS client that works after each reboot and then
> eventually
>> hangs when the afs area is accessed.  I am running openafs 1.4.9 that
> I compiled
>> on the system (I have tried many versions of the openafs client with
> the same
>> results).  The OS is OpenSUSE 10.3.  I have two other systems with the
> same
>> OS that are working fine.
>> I have searched /var/log/messages.  I have checked the config files.
> User
>> authentication works fine (even when the system is hanging).  If I run
> the
>> command 'ls -l /afs' that window is hung.  If an afs user logs in when
> the
>> system is in a bad state the session immediately hangs because it
> can't cd
>> to the afs home dir.  I don't know what to do other than reboot.  Can
> someone
>> tell me what else to try to find out why this system is hanging?
> Thanks,
> If you really are using the command "ls -l /afs", I have always
> understood that this is getting information about the whole of AFS
> space, that is, the root directories for all AFS cells; naturally this
> will take a long time.  This may not solve your problem, but the command
> as given is a bad (TM) idea.  Of course, the command "ls -l
> /afs/CELLNAME" where CELLNAME is the name of your cell is a much better
> idea.

It depends on your root.afs volume. With dynroot (as far as I understand),
the involved effort is not great, and doing a plain listing of a static
root.afs shouldn't take ages either.

Most importantly, even if there is a longer batch of accesses that makes one
process take forever, this should not freeze the entire machine's AFS
connectivity, right?

What happens if a user w/ AFS home logs on before ls - /afs? Does this not
generate the bad state?

  - Felix