[OpenAFS] Read-Write Disconnected Mode - How does it work?

Simon Wilkinson sxw@inf.ed.ac.uk
Mon, 2 Feb 2009 08:28:37 +0000

On 2 Feb 2009, at 01:48, Jason Edgecombe wrote:
> I had some trouble with discon mode. I compiled an RPM from the 1_5  
> branch in CVS. I can "find . -type f | cat > /dev/null", then I can  
> fs discon offline. Problems that I had:
> * ls couldn't find "."; reconnecting and disconnecting fixed it

This suggests that you didn't cache the directory - either it was  
skipped by the find, or the callback on it had been expired by the  
time you went offline. Pinning should solve these kinds of issues.

> * I tried running my newtests perl scripts, but that failed with  
> some perl errors.

Were these issues related to the filesystem, or other problems? Are  
those tests available somewhere?

> * vi complained of multiple swap files when trying to edit the  
> config file for my test suite.

Odd. Can you get an fstrace log of what vi was trying to do when it  
complained - I can vi whilst disconnected without any problem.

> * fs discon online said I didn't have the proper permissions when  
> run as root.

Did you have tokens? The error code you're getting is UAEACCES, which  
suggests not.

> * "fs discon online -force" made AFS freeze

Again, strange. Did you get cmdebug -long output to see if it's hung  
on a lock, or alt-sysreq-t output to see where each process is blocked?