[OpenAFS] Re: servers not establishing a quorum

lists@drewstud.com lists@drewstud.com
Tue, 6 Apr 2010 13:09:09 -0400 (EDT)

Here is what I get from 7003 -long on each server=0Ahttp://pastebin.com/L8B=
JtNst=0A=0ATwo of our servers have the same local db version  and sync site=
 db=0AThe other one has v 1.1 for both. They all have Sync host showing as = we have tried is removing the new afs server from CellSrvDB,=
 and stopping the openafs processes on that server (putting it back to what=
 it was before we tried adding it), and the two original servers were able =
to quorum.=0AOnce we added this new server back, no more quorum. =0AWe veri=
fied that the hosts files are correct and match, and they do. =0AWe also st=
opped the vlserver process on two of the servers, and left it up on one (th=
is is with the new server in CellSrvDB) and it never established a quorum, =
even though it was the only one alive.=0AWe were however able to get vos li=
staddrs to show the new fileserver, which is good, but we are still stuck. =
=0AWhat has to be in place for a quorum to take place? I am certain we are =
missing something simple here.=0A=0AThanks!=0A=0A-----Original Message-----=
=0AFrom: "Andrew Deason" <adeason@sinenomine.net>=0ASent: Tuesday, April 6,=
 2010 11:02=0ATo: openafs-info@openafs.org=0ASubject: [OpenAFS] Re: servers=
 not establishing a quorum=0A=0AOn Tue, 6 Apr 2010 09:11:35 -0400 (EDT)=0Al=
ists@drewstud.com wrote:=0A=0A> udebug of 7002 of all three servers:=0A> ht=
tp://pastebin.com/SZyM4BC7=0A=0A7003 is vlserver, 7002 is ptserver. But I e=
xpect the output for either=0Awould be similar.=0A=0A> They all show the sy=
nc host as (which is what it gets set to=0A> when a quroum cannot b=
e established right?)=0A=0AIt says they have not yet established quorum. Wh=
at tells you that quorum=0Awill _not_ be established is that all of the hos=
ts are voting for=0Athemselves, so they will never agree on a leader.=0A=0A=
> vos listaddrs shows the two original afs servers, but not the current=0A>=
 one.=0A=0Avos listaddrs lists fileservers.=0A=0A> What else could I be mis=
sing or need to check? I am sure it is=0A> something very simple.=0A=0A'ude=
bug 7003 -long' on each one.=0A=0AIt looks like they may disagree on what t=
he dbservers are, but 'udebug=0A-long' will say what they think they are.=
=0A=0A-- =0AAndrew Deason=0Aadeason@sinenomine.net=0A=0A___________________=
____________________________=0AOpenAFS-info mailing list=0AOpenAFS-info@ope=