[OpenAFS] Trying to use OpenAFS-1.5.xx with Linux

Dale Pontius pontius@btv.ibm.com
Tue, 23 Feb 2010 10:08:37 -0500

Derrick Brashear wrote:
> <snip>
> We suggested not using 1.5.71 with Linux. 1.5.72 is really the most
> interesting anyway.
>> I had the most success with 1.5.72.  It built, started, and mounted
>> /afs.  I could see my home directory and another departmental directory
>> over which I have control.  That departmental directory had several
>> mount points directly under it, and I could see those, as well.  It also
>> had a directory "Data" and several mount points, "dataN" (for several
>> values of N) and I could NOT see those, no mount point, no data, nothing.
>> I also tried "fs discon -offline" and indeed got offline, with
>> anticipated data visiblity.  But when I tried "fs discon -online" I was
>> told as both root (no token) and myself (with token) that I didn't have
>> enough authority.
> Quote the error?
I just moved back to 1.5.72, to check this out.

First off, I can now disconnect and reconnect, without error.  So I
can't give you the specific and exact error message any more, since I
don't see it. 
Second, when disconnected, I don't see my cached data, any more.  For
that matter, I looked and it doesn't appear...

Scratch that.  I just did a bit more fiddling about, looking at data
while online, then going offline.  This time while offline, my directory
listings looked messed up except for those places where I'd actually
read files.  By messed up I mean permissions , owner, group, sizes
(basically all standard metadata) missing or changed to "??????".  But
where I'd actually been reading files, the metadata was correct.

Then I just tried to go back online.  Now I get the old error:
localhost ~ # fs discon -mode online
fs: You do not have the required rights to do this operation

Next I figured I'd grab a token for root, using my afsid as
"-principal", and I'm reconnected.  What seems odd here is that at first
root didn't need a token to reconnect, now it does.

Another observation.  On my previous testing, some mount points were
missing, along with all of their data.  This time those mount points are
present - mostly.  My data seems to be all present, with the exception
of some "holes".  The overt symptom is that I have a symlink, and if you
try "ls -l" on the parent directory to look at that symlink you get
"linkname -> " with the target showing up as blank.  I can go to another
afs client and find that target of that symlink.  Back on the 1.5.72
client, in some cases I can go directly to the target of the symlink and
see that the data is present.  But in some (currently one, but not
exhaustive testing) I go directly to the symlink target, and the data is
missing.  In this one case, the missing data shares a volume with other
data that is properly present.

Is this helping at all?

Am I testing, or merely distracting?

I'd really like to get disconnect capability for Linux laptop use, and
am willing to help by testing.  Gentoo makes building easy, so I can
swap back and forth between 1.4.x and 1.5.x fairly quickly for testing
purposes.  But I want to help, not hinder or distract.

Dale Pontius

Dale Pontius
Senior Engineer
IBM Corporation
Phone: (802) 769-6850
Tie-Line: 446-6850
email: pontius@us.ibm.com

This e-mail and its attachments, if any, may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply e-mail and delete all copies of this message from your system without copying it and notify sender of the misdirection by reply e-mail.