[OpenAFS] Trying to use OpenAFS-1.5.xx with Linux

Derrick Brashear shadow@gmail.com
Mon, 22 Feb 2010 16:25:42 -0500

On Mon, Feb 22, 2010 at 4:15 PM, Dale Pontius <pontius@btv.ibm.com> wrote:
> I'm attempting to get OpenAFS-1.5.xx running with Linux, in order to
> gain disconnect/reconnect capability on a laptop. =A0I normally run 1.4.1=
> or 1.4.12_pre for normal use. =A0(Running 1.4.12_pre to get something tha=
> will work with a 2.6.33-rc kernel.)
> I've made 3 stabs at it so far. =A0(By the way, on 2.6.33-rc8 with Gentoo
> Linux)
> 1.5.69 built OK, but segfaulted as soon as I tried to start the client
> daemon.
> 1.5.71 built OK and started OK, but results were horribly inconsistent.
> Sometimes I could klog and get a token, sometimes not. =A0I never saw /af=
> properly mounted with content.

We suggested not using 1.5.71 with Linux. 1.5.72 is really the most
interesting anyway.

> I had the most success with 1.5.72. =A0It built, started, and mounted
> /afs. =A0I could see my home directory and another departmental directory
> over which I have control. =A0That departmental directory had several
> mount points directly under it, and I could see those, as well. =A0It als=
> had a directory "Data" and several mount points, "dataN" (for several
> values of N) and I could NOT see those, no mount point, no data, nothing.
> I also tried "fs discon -offline" and indeed got offline, with
> anticipated data visiblity. =A0But when I tried "fs discon -online" I was
> told as both root (no token) and myself (with token) that I didn't have
> enough authority.

Quote the error?