[OpenAFS] More Quick Start Woes: afsd: Can't mount AFS on /afs(22)

Derrick Brashear shadow@gmail.com
Wed, 29 Sep 2010 10:26:41 -0400

On Wed, Sep 29, 2010 at 10:02 AM, Phillip Moore
<w.phillip.moore@gmail.com> wrote:
> ARGHH!!!!
> I am not sure which of the 3 or 4 things I tried resolved the problem, bu=
t I
> had NOT been looking at dmesg output, and it showed:
> You must reload the AFS kernel extensions before remounting AFS.
> I rebooted when the docs suggested, /afs didn't mount, so then I started
> tweaking things. =A0I simply re-ran "openafs-client start", but that was =
> sufficient. =A0One of the changes fixed this, but I can't tell which one.
> A second reboot resulted in AFS mounting fine. =A0I'm going to try to
> reproduce this, and see if I can't figure out exactly why it didn't work.

well, you must unload the module before you try to mount again.

> If I'm going to patch the QSG, I want to make sure what I document actual=
> works...
> Thanks for everything so far.
> On Wed, Sep 29, 2010 at 9:48 AM, Derrick Brashear <shadow@gmail.com> wrot=
>> On Wed, Sep 29, 2010 at 9:44 AM, Phillip Moore
>> <w.phillip.moore@gmail.com> wrote:
>> > No, I just tried with -dynroot, and the only visible difference is
>> > another
>> > line of verbose output:
>> > afsd: Enabling dynroot support in kernel.
>> > Fails with the same error.
>> Ok. Both "can't manage to mount root.afs" and "some problem with the
>> client itself" manifest as error 22, so it was worth trying (and
>> asking).
>> I take it the kernel message log has nothing of note?