[OpenAFS] rhel6 64bit pam_afs_session

Jonathan Nilsson jnilsson@uci.edu
Wed, 08 Jun 2011 12:10:10 -0700

Turns out I just needed some more coffee...

> That means pam_afs_session is not running, which probably means that
> something else in your PAM configuration is causing PAM to finish before
> getting to the lines that you excerpted above.

Well, this is embarrassing... turns out that RHEL6 isn't using 
/etc/pam.d/system-auth any more for sshd. The correct file is 
/etc/pam.d/password-auth (though system-auth is still used for other services... 
grr... more config files to manage!)

Everything works now! Thanks for pointing me in the right direction!

>> I found that I had to configure pam_afs_session with --libdir=/lib64
>> otherwise I would get "file not found" errors in /var/log/secure.
>> ./configure --prefix=/usr --libdir=/lib64
> That should not have been required.  Could you show the make install
> output from the package when you just use --prefix=/usr?

It did install to /lib64/security this time without using --libdir! Sorry about 
that. I bet what happened was that I typed "--libdir=/lib" the first time I 
tried it (we used to use only 32-bit systems so I could see myself typing that 
out of habit).

Computing Services
School of Social Sciences
SSPA 4110 | 949.824.1536