[OpenAFS] Installing OpenAFS 1.6.0pre6 on Snow Leopard (MacBookPro2,2) not working

John Tang Boyland boyland@cs.uwm.edu
Wed, 22 Jun 2011 08:24:12 -0500

Derrick Brashear wrote:
] On Tue, Jun 21, 2011 at 4:20 PM, John Tang Boyland
] <boyland@pabst.cs.uwm.edu> wrote:
] > Today after not using OpenAFS for a few weeks (after at least one restart
] > when I increased RAM from 2GB to 3GB),
] > I noticed that OpenAFS wasn't working: /afs was empty.  "fs checks"
] > didn't report any problems.  kinit/aklog worked just fine.
] >
] > I tried restarting OpenAFS manually using:
] > $ sudo /Library/StartupItems/OpenAFS/OpenAFS
] which shouldn't exist in a 1.6.0pre6 install; afs isn't started that
] way now and not for quite some time
] sudo rm /Library/StartupItems/OpenAFS/OpenAFS
] /Library/LaunchDaemons/org.openafs.filesystems.afs.plist

Done. (I wonder if this hanging around has been causing all my problems?
Should newer installs remove it?)

] and then reboot.

I had to force quit the installer (it didn't want to close),
and then on when shutting down, it hung and had to be powered down,
but then when I immediately resarted again, it was able
to go down.  Then I reinstalled pre6 and everything went fine
and after another non-hanging restart, things are working fine.