[OpenAFS] OpenAFS-1.7.1 on Windows 7 32 bit

Jeffrey Altman jaltman@your-file-system.com
Fri, 16 Sep 2011 16:13:38 -0400

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

On 9/16/2011 2:33 PM, Jeff Blaine wrote:
> Thank you for all of the effort getting this released.

You're welcome although after 1606 days of development
the best thanks would be a month not looking at the code
again. :-)

> Steps forward for me, but I'm not having as much luck
> as everyone else yet.  Important to note, probably, is
> that the private beta IFS release worked fine for me
> last I tried 2 months ago or so.  Quick grunts as to
> where to start debugging are welcome.
> At any rate, today:
> Uninstalled KfW and OpenAFS, including wiping out dangling
> dirs on disk and deleting registry keys, and rebooted.
> Dropped our CellServDB and krb5.ini in the proper
> places.
> Installed 64-bit and 32-bit OpenAFS, no integrated logon,
> and don't use DNS for cell lookup, then rebooted.
> Installed 64-bit and 32-bit KfW 3.2.2 from Secure
> Endpoints' website.
> Started NIM, it knew my realm and username, got ticket
> and AFS token.

NIM and KFW are completely independent of OpenAFS.
There is no reason to touch their configurations.
Since you were attempting to create a clean slate, did
you delete the %windir%\temp\afscache file?

> tokens.exe shows this.
> aklog.exe -d -force (for kicks) shows all is fine.

you had tokens and forcibly set them again.  not sure why that would do

> fs.exe checkservers reports all is fine.

"fs checkservers -all -fast" would be more useful.

> fs.exe lsmount \\AFS\our.org\user\jblaine hangs indefinitely
> and cannot be Ctrl-C'd.  Trying to kill the process via Task
> Manager appears to do nothing.  I've waited several minutes
> now.

fs minidump will generate a minidump in %windir%\temp\ for the
afsd_service.exe.   This will permit a developer to see what the process
is stopped waiting for something to happen.

Jeffrey Altman

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

Version: GnuPG v1.4.9 (MingW32)