[OpenAFS] mmap issue?

Eric Chris Garrison ecgarris@iu.edu
Fri, 23 Mar 2012 14:52:25 -0400

This is a multi-part message in MIME format.
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit


I've had a complaint from one of our users.  He says:

"I just had afs do a very very nasty thing to me.   I ran a program on
a data file and for some unknown reason the file was totally corrupted
after running this program.   I can absolutely certify that the problem
is not the program itself because I ran exactly the same program on a
local disk and it did what I was asking it to do without corrupting the

I suspect strongly this problem is created by memory mapping of the file
which I think this program is implicitly using.   The actual thing I was
running was a perl script, but it was calling programs I am pretty sure
do memory mapping for io speed."

I asked him for details, and he is using code that uses this:

"I was running a program in the "Antelope" package sold by brtt.com.
The particular program is a perl script called dbfix_calib. However, the
offender is almost certainly this line
system( "dbjoin $dbname.$table calibration | dbset -v - $table.calib
'calib == NULL' calibration.calib" );"

He is running OpenAFS 1.5.77 for MacOS 10.6.8, and our servers are at

I've searched for this, and it appears mmap operations used to be a
problem.  At what version of OpenAFS (server and client) should we be at
for this to not be a problem?

Thank you,

Eric Chris Garrison | Principal Mass Storage Specialist
ecgarris@iu.edu     | Indiana University - Research Storage
317-278-1207        | Jabber IM: ecgarris@iupui.edu

Content-Type: text/x-vcard; charset=utf-8;
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;

org:Indiana University;Research Storage
adr:;;535 W. Michigan st;Indianapolis;IN;46202;USA
title:Principal Mass Storage Specialist