[OpenAFS] OpenAFS 1.8.0 alpha 1 available

Gaja Sophie Peters gaja.peters@math.uni-hamburg.de
Fri, 30 Dec 2016 21:07:46 +0100

Am 29.12.16 um 17:22 schrieb Gaja Sophie Peters
	on openafs-info@openafs.org:

> I guess this is
> more of a "success" story, than a bug, so I'll provide my feedback
> (little as it may be) here, in case it may be helpful to anybody.

[skip the steps for building]

> - Next I installed with "dpkg -i" the three packages that are needed for
> a client-install and courageously rebooted - only to find out that AFS
> wasn't find my home-dir. (All other directories were working fine,
> except the one above my homedir and my homedir...)
> - Any combination of "fs flush" "fs flushmount" and "fs flushall" didn't
> help either, so I manually cleared out the AFS-cache and restarted again.

Hm, maybe some kind of "bug-report" after all. Today when I logged in 
with SSH with a user that has an AFS-Homedirectory, I had the same 

> Could not chdir to home directory /afs/math.uni-hamburg.de/users/it/fmsv030: No such file or directory

Possible reason (not sure): The directory /afs/math.uni-hamburg.de/ is 
readable for system:anyuser - the next subdir 
/afs/math.uni-hamburg.de/users is readable by system:authuser (but not 
by "anyuser"), so during login (when my credentials aren't yet known to 
the system), "root" (or "the kernel") thinks, the directory 
/afs/math.uni-hamburg.de/users/it" doesn't exist. ls -al shows it at 
first as
	??????????   ? ?    ?       ?            ? it
and after some experiments with flush/flushmount as
	d?????????   ? ?    ?       ?            ? it
This state remains even after login. I could solve it one time by using 
fs flush / fs flushmount / fs flushall as root (not as logged-in user). 
After that, the directory appeared as normal and a regular SSH-Login now 
works as well without error.

However, after a reboot, I tried to reproduce the 
"make-the-directory-available-again" without success. However much I 
"flush"ed, the directory remained unaccessible:

$ cd /afs/math.uni-hamburg.de/users/
$ fs lsmount it
'it' is a mount point for volume '#math.uni-hamburg.de:users.it'
$ fs listacl it
fs: File 'it' doesn't exist

When I rebooted and logged in with a non-afs-user, then used kinit / 
aklog and checked the directory, it was there AND worked afterwards also 
on login with afs-user...

Apologies for the maybe unclear and confused description. As a final 
test, I made a cross-test and tried the same compile/install routine for 
openafs 1.6.20-2 and ssh-login worked there the first time (and the second)

Greetings (in the hope that any of this may be helpful),
Gaja Peters

P.S. All this on Ubuntu 14.04 with Kernel 3.13.0-106-generic, 
compilation of OpenAFS as described in the post 
Login(-attempts) were made with kinit / ssh -K