[OpenAFS] RE: OpenAFS

Derrick J Brashear shadow@dementia.org
Wed, 01 Nov 2000 14:39:55 -0500

--On 11/01/2000 01:26:13 PM -0600 "Neulinger, Nathan R." <nneul@umr.edu> 

>> -----Original Message-----
>> From: Greg Rhoades [mailto:gar@arrakisplanet.com]
>> Sent: Wednesday, November 01, 2000 1:21 PM
>> To: Neulinger, Nathan R.
>> Subject: RE: OpenAFS
>> >>> Neulinger, Nathan R writes:
>>   NNR> I didn't need it... Not sure why he did... The build worked
>>   NNR> just fine for me without washtool present.
>> did you have any trouble with the solaris 5.x kernel modules?  if i
>> don't use -k on the make, the build failes and it's always in the
>> MODLOAD section.  i went ahead and completed the compilation with -k
>> but don't know yet what all i'm missing.
> Only trouble I had was on 5.6 the build failed due to some curses symbols
> in gtx. It worked just fine on 5.7. In fact, I'm running the client on
> 5.7 and one linux 2.2.16 right now without any trouble.
>> also, were you concerned at all about the afs version of fsck not
>> being made available?  i know why, but don't know what exactly to do
>> about it.
> Well, yes and no... It means it most likely isn't suitable as a file
> server at the moment - although I wonder if maybe they changed it to
> operate like the linux version of 3.6? The linux version of the 3.6
> fileserver actually creates files that are visible on the filesystem,
> hence no need for a scary fsck replacement. (At least that's how it
> looked to me.)

bsd vfsck works just fine on solaris machines; I use it on mine that are 
running "Transarc AFS". The only problem is exit statuses don't necessarily 
match what the rc scripts expect. I assume a near-term patch will address 
that, but 35 production fileservers in the andrew.cmu.edu cell all run the 
bsd vfsck and are all solaris machines.

(the bsd vfsck is provided; only the modified vendor fscks are not)