[OpenAFS] Getting started

Silke Mueller silke@upb.de
Wed, 9 May 2001 16:50:09 +0200

On Mon, May 07, 2001 at 10:42:54AM -0400, Sam Hartman wrote:
> >>>>> "Silke" == Silke Mueller <silke@upb.de> writes:
>     Silke> I did just that and got a strange problem: I wasn't asked
>     Silke> any questions during installation of the packages and
>     Silke> dpkg-reconfigure didn't help, so has anybody an idea of
>     Silke> what went wrong?
> What packages did not ask you questions?  What do you have your
> debconf priority set to?  What isn't working?

During the whole installation I wasn't asked a single question, so I
tried to run dpkg-reconfigure -plow to be safe and tell the preconfigure
my default kerberos realm, which kerberos4 compatibility mode, which AFS
cell and so on, but even then there was no question asked, so I just tried
to run krb5_newrealm, but that didn't work:

castafiore:~# krb5_newrealm
This script should be run on the master KDC/admin server to initialize
a Kerberos realm.  It will ask you to type in a master key password.
This password will be used to generate a key that is stored in
/etc/krb5kdc/stash.  You should try to remember this password, but it
is much more important that it be a strong password than that it be
remembered.  However, if you lose the password and /etc/krb5kdc/stash,
you cannot decrypt your Kerberos database.
Improper format of Kerberos configuration file while initializing Kerberos code

I took a look at krb5_newrealm and discovered that the entry
"kdb5_util create -s" causes the output of
"Improper format of Kerberos configuration file while initializing Kerberos code".

Now I wonder what's wrong.


Silke Mueller