[OpenAFS] Linux AFS fileserver w/ journaled partitions works!

Alf Wachsmann alfw@SLAC.Stanford.EDU
Fri, 30 Nov 2001 08:55:53 -0800 (PST)

I have done a little testing with a Linux OpenAFS-1.2.2 fileserver
under RedHat7.2.

I've put SGI's kernel (2.4.9-13SGI_XFS_1.0.2) on the machine and configured
a FC connected Sun T3 (477.18 GB usable disk space) in the following way:
I've created one big volume group with LVM.
I've then created four logical volumes in that volume group.
I've put an ext2, ext3, XFS, and ReiserFS filesystem in these logical volumes.
Each filesystem is 70G large.

I've then mounted these filesystems as /vicepa through /vicepd on the server
and started an OpenAFS-1.2.2 fileserver (configured as "standalone" test cell).

I first tested these partitions locally on the server which also is an AFS
client. Then I configured a Solaris 5.7 and a RedHat6.2 client for my test
cell. Both clients are running OpenAFS-1.2.2.
I ran bonnie++ from these clients against each of the four server partitions.
See my other postings about the problems with a RedHat7.2 client.

-> To my surprise, all four filesystems worked flawlessly as OpenAFS
-> server partitions!!

I did the same tests with the server beeing an NFS server.
That worked, too, with all four partitions.

I am reluctant to post the bonnie++ results because I did not do any
optimization at all on the filesystems and the AFS clients ran with our
standard settings (contact me if you want the results).

I thought this might interest others as well.

See you at LISA,

  Alf Wachsmann                       | e-mail: alfw@slac.stanford.edu
  SLAC Computing Service              | Phone:  +1-650-926-4802
  2575 Sand Hill Road, M/S 97         | FAX:    +1-650-926-3329
  Menlo Park, CA 94025, USA           | Office: Bldg. 50/323
                http://www.slac.stanford.edu/~alfw (PGP)