[OpenAFS] Serious problem upon rebuild

Madhusudan Singh chhabra@eecs.umich.edu
Sun, 22 Sep 2002 19:56:35 -0400 (EDT)

On 22 Sep 2002, Derek Atkins wrote:

> Madhusudan Singh <chhabra@eecs.umich.edu> writes:
> > Thanks. The bootup process has been freezing on me (I have waited for
> > as long as 2 minutes for it to restart - tell me if you want me to
> > wait longer to get the dump). I finally logged in as single user and
> > chkconfig --del'ed the afs script.
> It hangs, and you've only waited two minutes?  If you're getting an
> AFS timeout (because the netowkr isn't working, for example, or your
> configuration is wrong), it can take much longer than 2 minutes.

Just ran insmod libafs.... under runlevel 3, no X :

Warning: loading libafs-2.4.19-LAPTOP-CUSTOM-17SEP2002.o will taint the
no license

Haven't tried running afsd.

First time I tried, I actually allowed afs to run (I am using a network
switching script that permits me to run afs and lpd after the system has
booted up - this has worked for almost 5 months perfectly).

The effect of changing the cacheinfo entry from 100000 to 90000 is that
the last warning has vanished. The thing just hangs at "Starting AFS
services ...."

> > Plus, I boot in runlevel 3. So, in light of that, could you explain
> > your last sentence ?
> I assumed you booted into runlevel 5.  I wanted to make sure you would see
> an Oops.

Well, the oops in the insmod is the tainted kernel message. I will now try
to run afsd and see what happens.

> Question: when the machine "hangs", can you ping it from another
> machine?

I will try this as well.