[OpenAFS] fs mkmount ??

Derrick J Brashear shadow@dementia.org
Mon, 5 Apr 2004 18:21:01 -0400 (EDT)

On Mon, 5 Apr 2004, Arthur Grotz wrote:

> > vos create -server et1.aa.bb.cc.dd -partition /vicepa -name root.afs - cell xx.bb.cc.dd -noauth
> > I have already '/vicepa' on separate partition (ext2)

i assume you didn't replicate root.afs yet.

> > when I try:
> > fs mkmount /afs/xx.bb.cc.dd root.afs
> > system error: fs:'/afs/xx.bb.cc.dd': No such device

the afs client should mount root.afs as /afs when you start it. does ls
/afs work? does fs lq /afs show root.afs with a quota of 5000?

i bet you have -dynroot enabled. in that case, you can't create
mountpoints there. (was afsd run with the -dynroot switch?)

> Yes i have running client. I tried "touch /afs/xx.bb.cc.dd root.cell" but already is the same error. So I shutdown afsd, client, and then "touch /afs/xx.bb.cc.dd root.cell", restart client, afsd and problem i still the same.
> but create mount "fs mkmount /afs/.xx.dd.cc.dd root.cell" doesn't send any errors.
> why I could create .xx but couldn't xx ?

those touch commands are something you seem to have made up, and have no
bearing on reality. ls and touch on /afs/cell.name (if xx.bb.cc.dd is
intended to be an address and not a name, it will be useless) should work
in that case. but touching root.cell isn't what you want, and i'm unsure
where you got the idea it would be helpful.

now, the convention is /afs/.cell is readwrite and /afs/cell is readonly,
so *if* you created and replicated root.cell already, you can create
mountpoints in /afs/.cell but not in /afs/cell; that's expected. to make
them visible in /afs/cell, vos release root.cell