[OpenAFS] no quorom elected again

J S vervoom@hotmail.com
Fri, 30 Apr 2004 12:50:03 +0000

>On 4/30/2004 08:29, J S wrote:
>>I tried the udebug cmd and found that the vlserver wasn't running on the 
>>AFS server. It wasn't in the BosConfig so I added it in and started it up. 
>>I stil got the quorum error after that (but much faster) so tried a bos 
>>restart -all and now I get this message:
>In the first message you showed ps output and there was a vlserver running. 
>  The vlservers must be running on the database machines listed in 
>CellServDB, they do not run on all the file servers.
>What is in your server CellServDB?  Did you check all the database servers 
>to see they match?  Did you check the time on each of those servers?  Is 
>this the first time you've tried moving volumes or any other administrative 
>operation since Jan 11 of this year?
>># vos move -id logs.proxy -fromserver cspc1n11e -frompartition /vicepa 
>>-toserver localhost -topartition /vicepe
>>Failed to create transaction on the volume 536871060
>>   VOLSER: permission denied, not a super user
>>vos move: operation interrupted, cleanup in progress...
>>clear transaction contexts
>>move incomplete - attempt cleanup of target partition - no guarantee
>>cleanup complete - user verify desired result
>These are odd messages that I am unfamiliar with.  Perhaps someone else 
>will recognize them.
>Ted Anderson

It's OK - I needed to add -localauth onto the end of the vos command, and 
after that it worked.


Express yourself with cool new emoticons http://www.msn.co.uk/specials/myemo