[OpenAFS] OpenAFS 1.3.63 on Windows XP

Chris Crowther chris@jm-crowther.co.uk
Fri, 30 Apr 2004 16:08:11 +0100

Hullo all,

	Anyone else had any problems with OpenAFS 1.3.63 on Windows XP?  It 
*was* working but now absolutely refuses to work - I can only try to map 
drives from the AFS Client dialog and not the AFS Configuration dialog 
(it doesn't populate the drive letter drop downs).  I say try because 
even though it creates the mapping it throws up a not accesible error, 
coupled with not being able to find message text for message number 0x 
(which seems a slightly odd message number to me) when I try to enter my 
cell's directory (which is, incidently, the only cell that shows up in 
the root; even though previously all the cells from CellServDB were 
showing up).

	Other times as soon as you go into the AFS root mapping the cell shows 
up, disapears, then afsd_service dies horribly.  I've also seen an error 
0xffffff come up too.

	I can't think of anything specificly that I've done to break AFS so 
wonderfuly.  I suspect I may have done it while I was beating integrated 
kerberos logins into submission.  I've tried removing OpenAFS 
completely: configuration et al. (even to the point of manualy removing 
the last vestiges of OpenAFS from the registry) then re-installing - 
still remains resolutely broken.

	Any ideas?

	(The local cell works fine on the Linux boxes; I've not tried on any 
other windows machines - I don't mind breaking my workstation, but if I 
start on other people's they tend to get tetchy).