[OpenAFS] why did I have to "vos create" twice on new cell setup? root.afs vs root.cell?

Adam Megacz megacz@cs.berkeley.edu
Sun, 11 Dec 2005 15:23:01 -0800

I took notes last time I set up a cell, and this time I ran through
them again.  I noticed that I had included the "vos create" command

  vos create $SERVERNAME /vicepa -name root.afs

  ... other stuff ...

  vos create $SERVERNAME /vicepa -name root.cell

(if this isn't enough info let me know and I will post the whole
command sequence).  This is really strange.  Nothing works without the
second command (I get the wonderfully descriptive "no such device").

What is the meaning of "root.afs" and "root.cell"?  Clearly one (or
both) of these must be a magical/special name -- if I had chosen
"festering.elephant" and "concrete.pants" as the arguments to "-name"
I bet this wouldn't have worked, right?

If so, can anybody point me to the documentation that explains which
volume names are "special" and what they mean?

  - a

PGP/GPG: 5C9F F366 C9CF 2145 E770  B1B8 EFB1 462D A146 C380

Q: "Won't the pendulum swing back?"
A: "It has never been a pendulum. Think tectonic plates instead."
                                              -- from patrick.net