[OpenAFS] why did I have to "vos create" twice on new cell setup? root.afs vs root.cell?

Derek Atkins warlord@MIT.EDU
Sun, 11 Dec 2005 18:33:23 -0500

Yes, these two ARE "magic" volumes.   The former, root.afs, is what gets
mounted at /afs (unless you're using dynroot).  If ALL your clients
use dynroot then you don't need a root.afs.  However, you still need
a root.cell.  That's what get's mounted at /afs/<cellname>


Quoting Adam Megacz <megacz@cs.berkeley.edu>:

> I took notes last time I set up a cell, and this time I ran through
> them again.  I noticed that I had included the "vos create" command
> twice:
>  vos create $SERVERNAME /vicepa -name root.afs
>  ... other stuff ...
>  vos create $SERVERNAME /vicepa -name root.cell
> (if this isn't enough info let me know and I will post the whole
> command sequence).  This is really strange.  Nothing works without the
> second command (I get the wonderfully descriptive "no such device").
> What is the meaning of "root.afs" and "root.cell"?  Clearly one (or
> both) of these must be a magical/special name -- if I had chosen
> "festering.elephant" and "concrete.pants" as the arguments to "-name"
> I bet this wouldn't have worked, right?
> If so, can anybody point me to the documentation that explains which
> volume names are "special" and what they mean?
>  - a
> --
> PGP/GPG: 5C9F F366 C9CF 2145 E770  B1B8 EFB1 462D A146 C380
> Q: "Won't the pendulum swing back?"
> A: "It has never been a pendulum. Think tectonic plates instead."
>                                              -- from patrick.net
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info

       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord@MIT.EDU                        PGP key available