[OpenAFS] OpenAFS Server - Windows XP Pro

Sherman Wilcox swilc0x@bellsouth.net
Sun, 27 Nov 2005 13:09:25 -0600

First question is whether or not OpenAFS Server is stable when running on  
Windows XP Pro. That is, is OpenAFS server for Windows ready for prime  
time? I ask because I can't seem to get it configured properly using the  
'Server Configuration Wizard'. Everything seems to install OK but the  
wizard crashes very consistently when I run it.

The PC is a dual Xeon Dell running Windows XP Pro. I just patched  
everything this morning via windowsupdate.microsoft.com. There's really  
nothing special or out of the ordinary about this box. In fact, I've tried  
to install OpenAFS server on several Dell PCs without success. Rather,  
I've tried to run the configuration wizard unsuccessfully. I've tried this  
on about three PCs without success. These computers are not part of a  
Windows domain, they're just stand-alone boxes.

I'm installing OpenAFS 1.4.0, the Windows MSI version using an  
administrator account. My test bed PC has two hard drives. The first one  
(C:) is the primary OS drive. The second drive is reserved totaly for  
OpenAFS. I've formatted this drive with a single NTFS partition (approx.  
230 GB) and assigned a drive letter (D:) to it. The D: drive has no data  
on it other than the "System Volume Information" folder.

When I installed OpenAFS I disabled integrated security and AFS crypt  
security. I enabled freelance mode as well as Lookup cells in DNS. When I  
run the "AFS Server Quick Start Wizard" I make the server the first server  
in a new AFS cell. I enter a cell name and assign the AFS and the admin  
account a password. I chose to make this server a "Backup Server". When  
the wizard asks me which drive to place an AFS partition I select the D:  
drive. However, the wizard does indicate that the D: drive does have data  
on it. Anyway, I select D: as the partition which assigns the AFS  
partition name as /vicepd. I configure the server as the "System Control  

OK, so I come to the end of the wizard and click the "Configure" button  
and then the wizard crashes with 65% left. The error is:

"Error: server or network not responding (0xFFFFFFFF)"

This error occurs right AFTER the wizard sets the ACL on root.afs.

Here are some screenshots of the errors as well as the error log:

If anyone has suggestions I'd love to hear them.