[OpenAFS] afsd: Error -1 in basic initialization

Maurizio Santini msantini@pictage.com.ar
Wed, 08 Feb 2006 01:27:17 -0300

I've compiled and installed successfully openafs-1.4.1-rc6 on a RedHat
7.3 with kernel-2.4.32 but when I run afsd I get:

afsd: Error -1 in basic initialization.

Running afsd -debug -verbose I get:
afsd: My home cell is 'tenroses.com.ar'
ParseCacheInfoFile: Opening cache info file
ParseCacheInfoFile: Cache info file successfully parsed:
        cacheMountDir: '/afs'
        cacheBaseDir: '/usr/local/openafs/etc/cache'
        cacheBlocks: 100000
afsd: cacheFiles autotuned to 3125
afsd: chunkSize autotuned to 18
afsd: dCacheSize autotuned to 2000
afsd: cacheStatEntries autotuned to 3000
afsd: 3125 inode_for_V entries at 0x8071ff8, 12500 bytes
SScall(137, 28, 17)=-1 afsd: Forking rx listener daemon.
afsd: Forking rx callback listener.
afsd: Forking rxevent daemon.
SScall(137, 28, 48)=-1 SScall(137, 28, 36)=-1 afsd: Error -1 in basic
SScall(137, 28, 19)=-1 SScall(137, 28, 0)=-1

I have the kernel compiled with CONFIG_NOHIGHMEM set and I wonder if
that is the problem.  I've also tried openafs-1.2.13 but again the afs
won't start.

"insmod /usr/local/openafs/lib/openafs/libafs-2.4.32.mp.o" (openafs-1.4.1-rc6) and "insmod /usr/vice/etc/modload/libafs-2.4.32.mp.o" (openafs-1.2.13) leads to the same error:

/usr/vice/etc/modload/libafs-2.4.32.mp.o: unresolved symbol kunmap_high
/usr/vice/etc/modload/libafs-2.4.32.mp.o: unresolved symbol
/usr/vice/etc/modload/libafs-2.4.32.mp.o: unresolved symbol kmap_high
Hint: You are trying to load a module without a GPL compatible license
      and it has unresolved symbols.  Contact the module supplier for
      assistance, only they can help you.

Thanks for your help.

Maurizio Santini
Maurizio Santini <msantini@pictage.com.ar>